So-net無料ブログ作成

Ubuntu16.04とかでLXCコンテナ内でtmuxを使う方法。 [Linux]

how to use tmux in LXC Container.
って書いとくと外人さんも来るかな?

やろうとした人はわかると思うけど、LXCコンテナ内でtmuxは使えなかったりした。回避方法はあったみたいだけど、根本的に解決できた。17.04になれば解決するんだが、いかんせんLTSじゃなかったりする。

https://www.ubuntuupdates.org/package/core/zesty/main/base/tmux

ここのdebファイルを使う。64bitだよね普通は。ってUbuntuの正式リポジトリじゃねぇかw。

wget http://security.ubuntu.com/ubuntu/pool/main/t/tmux/tmux_2.3-4ubuntu1_amd64.deb
sudo dpkg -i tmux_2.3-4ubuntu1_amd64.deb

ですぐに使えるようになる。別に無理やり17.04に上げる必要はない。まぁそのうちLTSに導入されるだろうから、すぐ使いたい人以外は気にしないw。今のLTSにバックポートはされるのかどうかは知らない。まぁそのまま使えるので、該当バージョンのaptで設定されれば入るというわけで。

なんか色が違うような気がしなくもないが気にしない。

コメント(0) 
共通テーマ:パソコン・インターネット

コメント 0