So-net無料ブログ作成
検索選択

libglib2.0-0でエラーが出たんだけど [Linux]

Ubuntuでapt upgradeをかけたらlibglib2を入れるときにエラーが出た。昔はAptでも依存性の問題を解決する自体に問題があったものだが、最近はそういうのにあたらなかった。でも、デスクトップ版でアップグレードをかけようとしたら出てきた。

ググると似たような事態を見つけた。
 http://askubuntu.com/questions/240147/libglib2-0-0-broken

sudo apt-get install -f libglib2.0-0=2.30.0-0ubuntu4

をすればいいと書いてあったのだが、そんなパッケージ無いとかエラーが出たので
sudo apt-get install -f libglib2.0-0

とやってみたらエラーが出ず色々ドカドカ入れられた。

そんでsudo apt upgradeは上手くいったみたい。どっちにしろ、GUIが必要ではないサーバ的には面倒が増えただけの気がする。lxcのイメージにはデスクトップに必要なパッケージは入らないことを願う。だってディスク領域無駄に消費するだけじゃん。

コメント(0) 

コメント 0